home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / rt2x00-9999 / rt2x00-9999.ebuild < prev    next >
Text File  |  2006-05-11  |  2KB  |  66 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/rt2x00/rt2x00-9999.ebuild,v 1.4 2006/05/08 12:58:31 uberlord Exp $
  4.  
  5. inherit linux-mod cvs
  6.  
  7. DESCRIPTION="Driver for the RaLink RT2x00 wireless chipsets"
  8. HOMEPAGE="http://rt2x00.serialmonkey.com"
  9. LICENSE="GPL-2"
  10.  
  11. ECVS_SERVER="cvs.sourceforge.net:/cvsroot/rt2400"
  12. ECVS_MODULE="source/rt2x00"
  13. ECVS_LOCALNAME="${P}"
  14.  
  15. KEYWORDS="-*"
  16. IUSE="debug"
  17. RDEPEND="net-wireless/wireless-tools"
  18.  
  19. MODULE_NAMES="
  20.     ieee80211/80211(rt2x00/ieee80211:)
  21.     ieee80211/rate_control(rt2x00/ieee80211:)
  22.     rt2400pci(rt2x00:)
  23.     rt2500pci(rt2x00:)
  24.     rt2500usb(rt2x00:)
  25.     rt61pci(rt2x00:)
  26.     rt73usb(rt2x00:)"
  27.  
  28. CONFIG_CHECK="NET_RADIO"
  29. ERROR_NET_RADIO="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
  30.  
  31. CONFIG_CHECK="FW_LOADER"
  32. ERROR_NET_RADIO="${P} requires support for Firmware module loading (CONFIG_FW_LOADER)."
  33.  
  34. pkg_setup() {
  35.     kernel_is lt 2 6 13 && die "${P} requires at least kernel 2.6.13"
  36.  
  37.     linux-mod_pkg_setup
  38.  
  39.     BUILD_PARAMS="KERNDIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
  40.     if use debug ; then
  41.         BUILD_TARGETS="debug"
  42.     else
  43.         BUILD_TARGETS="nodebug"
  44.     fi
  45. }
  46.  
  47. src_compile() {
  48.     linux-mod_src_compile
  49. }
  50.  
  51. src_install() {
  52.     linux-mod_src_install
  53.     dodoc CHANGELOG COPYING README THANKS
  54. }
  55.  
  56. pkg_postinst() {
  57.     linux-mod_pkg_postinst
  58.  
  59.     ewarn
  60.     ewarn "This is a CVS ebuild - please report any bugs to the rt2x00 forums"
  61.     ewarn "http://rt2x00.serialmonkey.com/phpBB2/viewforum.php?f=5"
  62.     ewarn
  63.     ewarn "Any bugs reported to Gentoo will be marked INVALID"
  64.     ewarn
  65. }
  66.